Delete BI aggregation API call results in 500 status code with a permissions error even though action is performed

CMK version: 2.1.0p13 CME
OS version: Ubuntu 20.04

when I execute the REST-API Call to delete a BI aggregation, I get an 500 internal server error with the details “Permission mismatch. See the server logs for more information”. But the BI aggregation is deleted though.
I found Werk #13954 where this problem is addressed and fixed, but for CRE.

Anything I do wrong or is there still an issue with Werk #13954?

Thanks in advance!

If i look at the werk checkmk/13954 at 2.1.0 · tribe29/checkmk · GitHub
It should be fixed with p9 with all editions. If CRE is mentioned there inside the git repo it affects normally all other editions.

Hm, I have 2.1.0p13 installed and it’s still not working. I tried it with powershell and with the CheckMK Interactive GUI but the error still occurs, even if the aggregation is beeing deleted.

I tested it in the interactive GUI of 2.1.0p24, and there the deletion works fine.