Disable warning of pending reboot windows updates

Is there a way to disable the warning for the “reqboot required to finish the updates” for the windows update plugin?

Did you meant this?

Yes I’ve seen this settings.
Firtst I had the the last two settings on default.
Then I changed them to 9999 days. the change hasn’t gone.
image

I’ve also checked the code /opt/omd/versions/1.6.0p19.cee/share/check_mk/checks/windows_updates and haven’t found where this setting will be used. or it’s too early in the morning?

I also not understand the setting parameters. Isn’t the forced reboot the planned reboot from the update service?

no chance to disable that?
these warnings are not really usefull for us

If you want to change the plugin then you need to modify the following lines.

        if reboot_required == 1:
        if status < 1:
            status = 1
        txt.append('Reboot required to finish updates(!)')

to

        if reboot_required == 1:
        txt.append('Reboot required to finish updates(!)')

With this modification the status is not changed if there is a reboot pending.

But i would say this is the most important information in bigger systems.

How long is your typical system in this status? If it is more than some hours i would consider some changes in the patch management :wink:

Hi

Thanks for your input. That’s working for now.
It would be nice if that can be configured in the WATO.

We could have this message for days. Don’t asks I know it’s not good.
We use this plugin only as information not as alerting.

anyway thanks a lot!!!