Do we have the ability to upload a company's MIB file if SNMP checks are failing because Check_MK doesn't have the right definitions

I tried walking thru the instructions to write my own check/plugin but I either get no response on commandline or I get to a page saying instructions are planned but not documented. In short how do I upload a companies MIB file to be used for SNMP communication?

You cannot just upload a MIB file somewhere and magically get new checks from that content.
The MIB only defines names for object IDs and sometimes mappings from integers to states or other meanings. But there is no syntax in the MIB that a computer can use to interpret the values.
This has to be done by a human author writing the SNMP check plugin.

See section 4 of the legacy documentation https://checkmk.com/cms_legacy_documentation.html as starting point and continue to read available check plugins.

1 Like

I followed those instructions and got as far as trying to test the inventory but I dont get a response when in the site on CLi.

This is out of my area of expertise but I have been trying to fumble my way thru it. I get to the point where i run the command to test the work and I get this error (this is after modifying the main.mk file under etc/check_mk dir): “Cannot read in configuration file /omd/sites/meta_mon/etc/check_mk/main.mk: Load config error: The all_hosts parameter was modified through an other method than: x+=a or x=x+a”
This is after run the the check_mk -I command [check_mk -I meraki snmp.meraki.com]

When I change my main.mk file to fix what its complaining about (namely adding just + in front of the =) I get the following error: " check_mk -I meraki snmp.meraki.com

Error in plugin file /omd/sites/meta_mon/local/share/check_mk/checks/meraki: invalid syntax (, line 15)

Hostname or tag specification ‘meraki’ does not match any host."

I think one of my issues is that the example on https://checkmk.com/cms_legacy_devel_snmpbased.html it says to create a file in the directory ~/local/share/check_mk/checks/meraki with the statement: snmp_info[“meraki”] = ( “.1.3.6.1.2.1.2.2.1”, [ “2”, “3”, “8” ] ). <----Value based on previous snmkpwalk command on step 1.4. Then in step 2.1 it says to create the same named file and instead have the statement:

def inventory_meraki(info):

Debug: lets see how the data we get looks like

print info
return []

def check_meraki(item, params, info):
return (3, “UNKNOWN - not yet implemented”)

check_info[“meraki”] = {
“check_function” : check_meraki,
“inventory_function” : inventory_meraki,
“service_description” : “NIC %s”,
“snmp_info” : ( “.1.3.6.1.2.1.2.2.1”, [ “2”, “3”, “8” ] )
} <-------Same value as the above statement.

based on the instructions it looks like its the same file as the one indicated in step 1.4. When I click on the link on this page to get more info [tutorial] I’m brought to a page that has the message: " Not yet written, sorry"

If it wasnt my entire wireless network or a 3 out of 4 of my storage devices. I would probably skip it but these are pretty important