Elasticsearch enable in checkmk

when we create the elastc search rule with port 9200 its getting affected all the service of the host .Everything is moving to critical.
is there any other way to enable elastic search other than this port 9200

is there any special agent plugin to be written
would it just be copying /omd/sites/limon/share/check_mk/agents/special/agent_elasticsearch to /usr/lib/check_mk_agent/plugins/? Do I need to do anything in WATO or will it know to just look at what’s in the directory?

did you enable the Special Agent at the Elasticsearch Host?

Hello Holger,

No, didnt enable the special agent at the elastc search host .
how to do that . Can you help me out how to enable the special agent

click on Hosts in Wato
grafik

then click on edit by your Host
grafik

Now Scroll to Data Source and select the appropiate Preference you want, i use Normal checkmkagent, all configured special Agents.

Hello Holger ,

This above changes done but still its getting affected to all the service of the host. Every service in that host getting shifted to critical . Giving error as Checkmk timeout