Error: Duplicate service description in Raw version 1.6.0p11

Hi,

I recently tried to upgrade old 1.2.6p11 to the latest and greatest 1.6.0p11 installed on debian 8, and that did not go very well, so I decided to follow the advice from the check_mk website, and build a completely new server, latest debian 10, and install Raw 1.6.0p11, and then import the hosts from the old version.

That worked better than the upgraded version, but still have quite a few issues.
One of the issues is this:

  • check_mk: ERROR: Duplicate service description ‘NTP Time’ for host ‘hostname’! - 1st occurrance: checktype = chrony, item = None - 2nd occurrance: checktype = ntp.time, item = None

What is interesting is that when I edit services for this host, I see a duplicate:

And from here if I click to move this broken (duplicate) sensor to disabled services - nothing happens. And if I move both NTP sensors to undecided, then I can disable them both, but that’s not really what I want.

What is even more interesting is that this is the case for 5 totally random hosts. There are 15 other hosts that have this NTP sensor and it works fine there, on old and new check_mk version.

Note that I still have old check_mk, and that NTP sensor works fine there, for those 5 problematic hosts.

Anyone else had the same issue? Any ideas where to look at?

Thank you!
Adnan

See Werk #10152: chrony: Do not discover if chrony can’t connect but ntp section is present

Avoid duplicate services for systems that have both chrony and ntp installed but are using ntp, in fact.

fixed in Version 1.6.0p12

HTH
Martin

1 Like

It is indeed solved in 1.6.0p12. I just did the update and the issue is gone.

Thanks a lot @martin.schwarz!

Best regards,
Adnan