Fake Downtime for a specific time

Hello everyone,
I’m new to using check_mk, I just created a topic “how to create a delay rule”, so now I’m trying to test this rule, this rule was created as follows in version 1.2.8p27 raw.

WATO - CONFIGURATION -> Host & Service Parameters -> Monitoring Configuration -> Delay Host notifications

I’m trying to send a downtime on an active host 172.xx.xx.xxx, but when setting the downtime it goes up again, is it possible to create a downtime for a specific time?

If so, how?

Thanks,

Hi,

go to your host and select the hammer symbol. There you can find an option for downtime. You can choose ‚from Now for‘. After the 60 minutes the downtime ist over.

Regards

Anastasios

2 Likes

Hi,

Thank you, it’s worked, but the notification rule doesn’t respect the delay rule notification.

I set 1 minute on delay rule to test quickly.
the delay rule is not working, what is the next step?




Hi,

you’ve just created a rule for host notifications. With host notifications checkmk means the check whose checking if your host is down or up (default is ping). So you need to create a rule whose called ‘delay service notifications’. The rule is for all services. You can find the rule in WATO - CONFIGURATION -> Host & Service Parameters -> Monitoring Configuration -> Delay Service notifications.

I hope it helps and works as well

Best regards

Anastasios

1 Like

Hi Anastasios,

This a rule already did created, but this rule doens’t create a “delay” to send a notification email with a time interval.

Hi Bruno,

This setting delays notifications about service problems by the specified amount of time. If the service is OK again within that time, no notification will be sent out.

What exactly do you need? Maybe I do not understand

thanks for your quick response, i understand how the services work thanks to you, but when i test them the rule does not work.
to test, I drop a service for 1 minute so that I can time the time to send the alert, that is, in this time interval I want it to delay delivery, but the case is that it doesn’t, the delay is set to 3 minutes after 3 minutes of a downtime it should send an alarm, delaying the sending of the message.

Hi Bruno,

during a downtime you can’t send alerts. Problem notifications are deactivated during the downtime

https://checkmk.com/cms_basics_downtimes.html

1 Like