GUI suggestion: Icons -> Actions

On a 1.6p16 instance.

As shown below, Icons should be renamed as Actions.
image

Is there a story why the column header named as Icons ?

The only thing I can think of… I-C-O-N-S (5 letters) A-C-T-I-O-N-S (7 letters)

One of the biggest problems with dashboards is figuring out how to make both a “clear” and also “compact” design, as the two items sometimes work against each other.

IMHO, 5 vs 7 letters is a weak argument, since we have “Status detail” as column head also.

2 Likes

Maybe, but consider the Icons column by default holds tiny item(s). Where Status Detail is going to contain much larger content (generally speaking). It’s just a UI thing.

Tables are wonderful things, but can cause such issues in a UI.

1 Like

Not to be picky, but shouldn’t 1st column head - “state” be “State” ?

1 Like

It is very easy - not all “Icons” are actions. If i open a graph this is no action.
The same for some other icons. If you can select a icon to quickset a downtime then it would be an action.
Action in monitoring context means that something is done and not only shown.

2 Likes

If i open a graph this is no action.

Open is an verb/action, isn’t it ?
Anyway, this is just an friendly suggestion from a new CRE user.
And there is no agreeing Vote. :grinning:

1 Like

No :slight_smile: you must think inside the monitoring context, not if you as a person do an action.

I agree with the OP. In English, an icon is literally just a picture of something, therefore a menu labeled “icons” would just be a list of pictures. In this case, I believe the most appropriate word would be “Options.”

Thanks for discussing this topic. A simple rename is not an option, because this column can contain actions, open view with more details, offer fly-over graphics and indicate a status. Not all of this is subsumed under “Actions”. Also, “Open” is no solution, as e.g. the status cannot open anything.

This requires more discussion. Until this is done, we keep the currently established “Icons”

Thomas

For me personally “Actions” would match better, because I can execute different “actions” like “execute a context-related command” or “open a context-related view”.

If you have such a hard time with it, then let your customers vote. After all, it should fit for us customers and not for the programmers who don’t work with the tool.