MongoDB Asserts PEND - No time difference

CMK version:2.0.0p23.cre
OS version:Ubuntu 20.04.4 LTS

Error message:no one

Output of “cmk --debug -vvn hostname”: MongoDB Asserts 0.00 Regular Asserts/sec, 0.00 Warning Asserts/sec, 0.00 Msg Asserts/sec, 82.39 User Asserts/sec, 0.00 Rollovers Asserts/sec, 0.00 Regular Asserts/sec, 0.00 Warning Asserts/sec, 0.00 Msg Asserts/sec, 0.00 User Asserts/sec, 0.00 Rollovers Asserts/sec, 0.00 Regular Asserts/sec, 0.00 Warning Asserts/sec, 0.00 Msg Asserts/sec, 0.00 User Asserts/sec, 0.00 Rollovers Asserts/sec

Output of “cmk --debug -vv hostname”: MongoDB Asserts PEND - No time difference

image

I don’t see any errors debugging plugins agent/server and all informations are correctly present on piggyback files:

/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo01:<<<mongodb_asserts:cached(1657896861,60)>>>
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo01-regular 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo01-warning 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo01-msg 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo01-user 154205293
--
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo02:<<<mongodb_asserts:cached(1657896867,60)>>>
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo02-regular 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo02-warning 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo02-msg 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo02-user 154205317
--
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo03:<<<mongodb_asserts:cached(1657896769,60)>>>
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo03-regular 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo03-warning 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo03-msg 0
/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo03-user 154204722

Any idea?
Thanks!

Anyone who can drive me to do a deep debug?

Hi!
I tried to put the plugin into “90” folder (for caching) without success
I also put some print for debug into the check “mongodb_asserts”.
I print the “info” variable and yield line, invoking the plugin the output is:

cmk --debug -v --detect-plugins mongodb_asserts rs_keycloak

Checkmk version 2.0.0p23
+ FETCHING DATA
[PiggybackFetcher] Execute data source
Piggyback file '/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo03': xxxxx-mongo03
Piggyback file '/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo01': xxxxx-mongo01
Piggyback file '/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo02': xxxxx-mongo02
+ PARSE FETCHER RESULTS
Received no piggyback data
[['regular', '0'],
 ['warning', '0'],
 ['msg', '0'],
 ['user', '13751606'],
 ['rollovers', '0'],
 ['regular', '0'],
 ['warning', '0'],
 ['msg', '0'],
 ['user', '13751232'],
 ['rollovers', '0'],
 ['regular', '0'],
 ['warning', '0'],
 ['msg', '0'],
 ['user', '13751110'],
 ['rollovers', '0']]
0 0.00 Regular Asserts/sec [('assert_regular', 0.0)]
0 0.00 Warning Asserts/sec [('assert_warning', 0.0)]
0 0.00 Msg Asserts/sec [('assert_msg', 0.0)]
0 26.58 User Asserts/sec [('assert_user', 26.57969123438073)]
0 0.00 Rollovers Asserts/sec [('assert_rollovers', 0.0)]
0 0.00 Regular Asserts/sec [('assert_regular', 0.0)]
0 0.00 Warning Asserts/sec [('assert_warning', 0.0)]
0 0.00 Msg Asserts/sec [('assert_msg', 0.0)]
0 0.00 User Asserts/sec [('assert_user', 0.0)]
0 0.00 Rollovers Asserts/sec [('assert_rollovers', 0.0)]
0 0.00 Regular Asserts/sec [('assert_regular', 0.0)]
0 0.00 Warning Asserts/sec [('assert_warning', 0.0)]
0 0.00 Msg Asserts/sec [('assert_msg', 0.0)]
0 0.00 User Asserts/sec [('assert_user', 0.0)]
0 0.00 Rollovers Asserts/sec [('assert_rollovers', 0.0)]

MongoDB Asserts      PEND - No time difference

But this do not point me to any direction to solve the issue

UPDATE!
Not sending the results to core by "-n" switch the plugin works as expected :thinking:

cmk --debug -vn --detect-plugins mongodb_asserts rs_keycloak

Checkmk version 2.0.0p23
+ FETCHING DATA
[PiggybackFetcher] Execute data source
Piggyback file '/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo01': xxxxx-mongo01
Piggyback file '/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo02': xxxxx-mongo02
Piggyback file '/omd/sites/xxxxx01/tmp/check_mk/piggyback/rs_xxxxx/xxxxx-mongo03': xxxxx-mongo03
+ PARSE FETCHER RESULTS
Received no piggyback data

MongoDB Asserts      0.00 Regular Asserts/sec, 0.00 Warning Asserts/sec, 0.00 Msg Asserts/sec, 2.30 User Asserts/sec, 0.00 Rollovers Asserts/sec, 0.00 Regular Asserts/sec, 0.00 Warning Asserts/sec, 0.00 Msg Asserts/sec, 0.00 User Asserts/sec, 0.00 Rollovers Asserts/sec, 0.00 Regular Asserts/sec, 0.00 Warning Asserts/sec, 0.00 Msg Asserts/sec, 0.00 User Asserts/sec, 0.00 Rollovers Asserts/sec
execution time 0.1 sec | execution_time=0.080 user_time=0.080 system_time=0.010 children_user_time=0.000 children_system_time=0.000 cmk_time_agent=0.000