Mount options of /home Exceeding: nosuid,nodev but /proc/mounts says they Are nosuid,nodev

From the server /proc/mounts:
/dev/mapper/rhel-home /home xfs rw,seclabel,nosuid,nodev,relatime,attr2,inode64,noquota 0 0

This is occurring on a dozen of 400 servers, often times only on one of a cloned pair.

Any guesses? I know I can just disable this check, but I’d rather have it just be correct Thanks!

Since these change on updates (a lot), Automatic Refresh (Tabula Rasa) is your friend to clean these up per server.

Doesn’t “fix” the issue, only until the next time.

1 Like

A better friend, is ‘undecided’.

Move a service from Monitored to Undecided. Then move it back to Monitored.

The movement of Undecided to Monitored will update the state of the settings.

2 Likes

Unfortunately my server is in a non-internet connected environment, so autorefresh isn’t going to work, but I will try the “undecided” workaround.

Any… theories on what’s wrong? I mean, those /proc/mounts settings should never have changed, it’s been set to nosuid,nodev since install. Is the check just bad? I can just disable it if it’s useless, is this something I should bug report?

moving to undecided and back again didn’t work. I tried it on 50 different hosts before checking too, ack. clickyclickyclicky

I’m working on just disabling this broken check.