NTP servers: unreachable, Reference ID: 00000000


One of my proxmox servers reporting back with

NTP servers: unreachable, Reference ID: 00000000

However on the server all seems to be fine…

# chronyc -n tracking
Reference ID    : 3E508B39 (
Stratum         : 4
Ref time (UTC)  : Fri Mar 10 20:41:37 2023
System time     : 0.000005309 seconds fast of NTP time
Last offset     : +0.000003049 seconds
RMS offset      : 0.000011524 seconds
Frequency       : 9.430 ppm slow
Residual freq   : +0.000 ppm
Skew            : 0.006 ppm
Root delay      : 0.004372039 seconds
Root dispersion : 0.011157017 seconds
Update interval : 520.3 seconds
Leap status     : Normal

CMK version:

OS version:
Ubuntu 22.04.1 LTS

Error message:
NTP servers: unreachable, Reference ID: 00000000

Hi @Imperial7693,

what Checkmk Agent Version are you using? Is it the same as your current Checkmk Server?

It seems that you do your NTP is done with chronyd but you still have the ntpd installed and probably running.

Can you make sure that you either use chrony or ntpd? :slight_smile:



I have Agent Version: 2.1.0p20. Same as on the other proxmox hosts.
The proxmox system is using chrony.


Hey @Imperial7693
could you please provide some agent output from the agent?

I think you have the chronyd section and the ntpd section in the output. That’s the reason why you get two different services. (Chrony and NTP)

If you execute ntpq -p you should get NTP servers: unreachable, Reference ID: 00000000.
That means you have ntpd installed. You can check with systemd if ntpd is running using sudo systemctl status ntp.service because you have chrony installed and configured I would suggest that you uninstall the ntp package or at least disable it using sudo systemctl stop ntp.service && sudo systemctl disable ntp.service.
After that you can verify if ntpd is still running with sudo systemctl status ntp.service.

In the end you want to ask yourself why are there two timesync programs installed. Normally you install Proxmox on Debian. Chrony is not the default timesync program on Debian as far as I know.
You can still use Chrony but then take care that there are no other timesync programs running/interfering.

Hope that helped. Looking forward to your answer.


I think I read he is not using Debian but Ubuntu. Ubuntu for synchronising time actually uses timedatectl / timesyncd by default and chrony is the default recommendation for running a time server.

In my case and I guess for him as well, ntpd is not even installed.

However, running Check MK RAW 2.1.0p22 and matching agent version, I can confirm the issue as I got the same with one my servers. (All others seem to have no issues and there are at least three which are exact copies besides hostname and IPs)
It also is not a persistent issue in terms that it never seems to be able to reach servers, but I get a critical alarm every 15 minutes (Which I think is the check interval, if I remember my configuration right) and goes back to OK after a minute. I did not check when exactly it went back to OK, because the one minute interval for the mails may be due to restrictions how often mails are sent.

Hi, I have resolved my issue with reinstalling the Proxmox host. But I also made slight changes on my PfSense box. Not sure which-one was the culprit. NTP is not part of Proxmox 7.x. So was not the issue.