Piggyback entry not available

Hi all,

I use for first time Piggyback and my issues:
cmk-server -> HostA -> HostB

Check_MK version 1.5

  1. I already create /omd/sites/mysite/tmp/check_mk/piggyback/HostB ,

thanks in advance…
Neeloj

Hi @neeloj,

you do not need to create any directories manually, this is done by checkmk.

You just need to make sure that the data section is enclosed by piggyback headers:

<<<<HostB>>>>
<<<sectionheader>>>
sectiondata
sectiondata
<<<<>>>>

The name of the spool file is irrelevant as just the content is appended to the agent output of HostA.

1 Like

thanks for you answer @r.sander.

I delete the folder.
The piggyback is empty.

ls /omd/sites/mysite/tmp/check_mk/piggyback

this is in my spool file on the HostA:

<<<< win-vm>>>>
<<< mem>>>
MemTotal: 8388148 kB
MemFree: 5779788 kB
SwapTotal: 1310720 kB
SwapFree: 1059500 kB
PageTotal: 9698868 kB
PageFree: 6839288 kB
VirtualTotal: 137438953344 kB
VirtualFree: 137438879996 kB
<<< uptime>>>
41282
<<<< >>>>

Now when I call cmk -d HostA , the folder HostB is created automatically.
And Why I dont see the piggy option when I create host ? are those related to eachother ?

This option is available from version 1.6 onwards.

1 Like

ops Okay thank you so much @r.sander :frowning: I use now 1.5, is there a workaround or so ? Because the structure is available…