Quicksearch not finding hosts on remote sites

Hi there

Today I tried to setup distributed monitoring according to the documentation at Distributed monitoring - Scaling and distributing Checkmk

I created a second site on the same server. I was able to create the distributed monitoring connection. See screenshot.

I successfully logged into the new site and the connection is online.
I then wanted to “move” one of my hosts to this new site. In the host properties I changed the “Monitored on site” setting and set it to the new site. I then did a full scan of the services and activated all the changes.

In the menu Setup → Hosts → → Host I can still access this host. I see that it is now being monitored on the new site.

But when searching via quicksearch for this new host, I cannot find it anymore.
I also opened the view Monitor → Overview → All hosts and tried searching for this host with CTRL+F but it is not in the list.
Should I not be able to find hosts that are monitored on other sites in the quicksearch?

CMK version: 2.0.0p18 (CEE)
OS version: CentOS Linux release 7.9.2009 (Core)

Error message: none

Yes, i have so many distributed systems and had no problems with search over more than 1 system. If you see the system in the all hosts view and there you see also the two sites then it must also work in your quicksearch. How does your all hosts view looks like?

The view shows all of my 478 hosts twice. Once for my main site and then again for the new site.
If I change a hosts “Monitored on site” setting to the new site, this host will vanish completely from the view.

I would like to have most of my hosts on the main site and only some specific host on the new site

Here is the problem. Is it possible that you configured the wrong port for your livestatus connection for the new site?.
Please check the livestatus port configuration for booth sites and compare it with your configuration inside the config menu.

1 Like

You are right! I used the default port 6557 for the second site, after changing it to 6558 everything works perfectly now! Thank you very much