SAML Authentication not working using check_MK 2.1.0p18 and SLES15SP4

**CMK version:2.1.0p18
**OS version:SLES15SP4


after upgrading our enviroment from SLES15SP3 to SLES15SP4 our SAML authentication is not working anymore. As we got the same error as fixed with werk #15040 we were confidently that our issue is fixed too, but unfortunately, after updating to 2.1.0p18 we still get the same error while starting the apache:

Starting apache...httpd2-prefork: Syntax error on line 236 of /omd/sites/dev_ad/etc/apache/apache.conf: Syntax error on line 14 of /omd/sites/dev_ad/etc/apache/conf.d/auth.conf: Cannot load /usr/lib64/apache2/ into server: /usr/lib64/ undefined symbol: EVP_KDF_CTX_new_id, version OPENSSL_1_1_1d


<IfModule !mod_auth_mellon.c>

        LoadModule auth_mellon_module /usr/lib64/apache2/


Changing LD_LIBRATY_PATH in ~/etc/enviroment does also not fix this issue.

Any advice is very welcome :slight_smile:




Hi everyone,

I am having the same issue with the same setup, only with CMK version 2.1.0p22 and SLES15SP4.

Is there any suggestion to it?

Seems as if mod_auth_mellon has not been shipped with Checkmk as I understood it should’ve been…? How can I check?

Thankful for any suggestions

Hi Carolina,

this issue is still not solved. We have a pending troubleshooting ticket at Tribe29 but i seems to be hard to find a solution for the dependencies.

Maybe it helps if you open a ticket too, so they see that this issue is a major problem for more than one costumer.