Service availability report only for prod servers

Hello,

I have tried to build a new service availability report only for hosts that have production tag but it does not work. Not for all hosts, i need a report only for prod environment.

What I tried:

  1. I made sure that i have Production attribute on my prod hosts.

  2. Monitor > All Hosts > Availability > Add To > Reports > Create a copy of “service_availability” and edit using the next Context / Search Filters :

Save & Go to list

  1. Generate report but it is empty

  2. If i remove the context filter the report includes all hosts (production and non production servers)

What am i doing wrong?

Other INFO:
Cmk version 2.1.0 ee

Thank you very much,
I appreciate your help
Robert

Have you tried it with different filter criteria?
Just to see if this is a problem with the attribute (filter doesn’t match because attribute / tag is for some reason not right) or with the filter mechanism (filter should match, but doesn’t)

Hello Elias

Yes, i did.

for example I’ve tried using “Folder” option with Linux Folder servers. Same result, the report is empty.

image

the name looks fine but it is empty (i tried to put another print-screen but it doesn’t work)

Linux - Service Availability Linux
Report created 2022-09-21 09:22:37 by (rchiru)
Timerange: August 2022 - from 2022-08-01 00:00:00 until 2022-09-01 00:00:00

Thank you,
Robert

Hm, that sounds more like a problem with the filter mechanism than with the attribute…

So the question is: Am I also doing something wrong, or is something wrong? I’ll investigate

EDIT: I fell into the trap that @athomaidis described. Now that I’ve filtered the content it works.

1 Like

What patch level do you use? There was a problem with availability views in reports some time ago

1 Like

Hi @rchiru ,
first, could you please use the latest 2.1 Version (2.1.0p12)?

I rebuild that and I’m able to filter successfully. Be careful, that in the reporting world, there are two ways of filtering:

Both ways are fine, but it depends on your use case.

Best regards
Anastasios

2 Likes

my current version:
OMD[checkmk]:~$ cmk -V
This is Check_MK version 2.1.0p2 CEE

I will update the application to the latest version in this evening then i will get back to you.
Thank you guys!!!

1 Like

i’ve just updated to 2.1.0.p12 and it works!

Thank you for your efforts, all of you!
Robert

2 Likes