Service/Host Label naming conventions

The Host labels discovered by the included plugins of Checkmk all start with cmk/. I currently writing a extension to automatically discover the Windows Server Roles as host labels to simplify the ruleset. I named the labels win_role/DHCP:installed or win_role/FileAndStorage-Services:installed for example but am unsure if this is a good naming convention or if something like ext/win_role/DHCP:installed would be better.

Has anyone any toughs or opinions?

Hi,
I like to prefer this label constructions:
Bool: : e.g. dhcp:true
Key/Value: : e.g. stage:integration
Key/Subkey:Value: /:value e.g. location/berlin:str_room2_123

I hope it will help you to find a way.

Cheers,
Christian