SNMP problem in Beta 2.0.0b6

Hi

I installed the SLES 15 SP2 version beta of checkmk and i cannot get SNMP v3 to work when trying to use that when configuring connection to one of my hosts.

When i run the test connection i get the following error.

SNMP Error on x.x.x.x: Invalid security level specified after -3l flag: md5
USAGE: snmpbulkwalk [OPTIONS] AGENT [OID]

Version: 5.8.dev
Web: http://www.net-snmp.org/
Email: …

When i configured it i choose the following options.

Security Level: authentication but no privacy
Authentication protocol: MD5 (MD5-96)
Security name: myuser
Authentication password: ******

The version of snmpbulkwalk is 5.8.dev according to it’s own information, can find it in all of these locations.
/omd/sites/mysite/bin/snmpbulkwalk -V → NET-SNMP version: 5.8.dev
/omd/sites/mysite/version/bin/snmpbulkwalk -V → NET-SNMP version: 5.8.dev
/omd/versions/2.0.0b6.cre/bin/snmpbulkwalk -V → NET-SNMP version: 5.8.dev
/opt/omd/sites/mysite/bin/snmpbulkwalk -V → NET-SNMP version: 5.8.dev

So i guess it’s bundled with checkmk.

I have tried with all of the SHA as authentication protocol to, for SHA-96 i get the same message but for the others(SHA-224 → 512) i get the error “SNMP Error on x.x.x.x: snmpwalk: Unknown user name (Exit-Code: 1)” on my host i can only choose between MD5 or SHA, it’s an Synology NAS.

Tried with security level set to “authentication and encryption” but same errors.

Testing with SNMPv1/2 works, but is not secure and confirms that connection to the host is working.

Regards

Marcus

Can you post the complete resulting snmpwalk command?

It is shown if you do a

cmk --debug -vvI hostname
The first snmpget or snmpwalk will be shown as a complete command after this you will get your error message.

I ran the command but not sure what do do next, if i run snmpwalk without options after in the cli i just get what parameters to add to the command and the first line says “no hostname specified”.

The cmk did not post any errors either.

The test in the GUI after just states what i wrote above with all available options, but no actual command line of what it tested.

I ran the cmk command as the user of the site, hope that was right?

Hmm, here it gets interesting, i activated the host anyway for monitoring despite the tests was not working, now it can fetch the information there and presents me with a lot of stuff i can monitor, but the tests still do not work nor do the full discovery when creating the host if i use a password with special characters.

So after some testing this is what i found.

  • Tests for SNMPv3 not working when adding a host.

  • Service scan do not work if using special characters in password when adding a host.

  • Service scan works when not using special characters in password, but tests still do not work for SNMPv3 under test page when adding a host.

Do you need for information, is there another command to run, should i run cmk with another options to reset it to default logging?

Regards.

Marcus