SNMP router shows down - how to remove ping check

CMK version:
2.1.0 RAW
OS version:
Docker on Debian
Error message:
Host Down

Hi.

My Mikrotik Router is not pingable by design. SNMP getting some data without issue. Have 8 services showing as good. I have searched the guide and forums and understand I should be able to do TCP port discovery instead of ping but depite trying rules for serveral hours I cannot get this to work.

I still get state down and 2 critical errors relating to the agent not being found despite having not checked the agent checkbox in host setup.

The default ping check seems to be causing the host down error depite my setting up a new rule for TCP.

Could anyone point me in the right direction please?

p.s. Loved the ease of installation on docker!