SNMPv3 and Cisco UCS FI, can discover but not monitor, other weirdness

**CMK version:**2.0.0p11
**OS version:**RHEL8.4

Error message:
SNMPv3 discovers device, but throws this error.
Starting job…
SNMP scan failed: Cannot fetch system description OID .1.3.6.1.2.1.1.1.0. Please check your SNMP configuration. Possible reason might be: Wrong credentials, wrong SNMP version, Firewall rules, etc.
Completed.

Output of “cmk --debug -vvn hostname”: (If it is a problem with checks or plugins)
This was too long to list, but here are some interesting screenshots

running the cmk deubg, I get this in the output

Checkmk version 2.0.0p11
Try license usage history update.
Trying to acquire lock on /omd/sites/BWI/var/check_mk/license_usage/next_run
Got lock on /omd/sites/BWI/var/check_mk/license_usage/next_run
Trying to acquire lock on /omd/sites/BWI/var/check_mk/license_usage/history.json
Got lock on /omd/sites/BWI/var/check_mk/license_usage/history.json
Next run time has not been reached yet. Abort.
Releasing lock on /omd/sites/BWI/var/check_mk/license_usage/history.json
Released lock on /omd/sites/BWI/var/check_mk/license_usage/history.json
Releasing lock on /omd/sites/BWI/var/check_mk/license_usage/next_run
Released lock on /omd/sites/BWI/var/check_mk/license_usage/next_run
Loading autochecks from /omd/sites/BWI/var/check_mk/autochecks/ZOSBWIUCSFI-A.mk

  • FETCHING DATA
    Source: SourceType.HOST/FetcherType.SNMP
    [cpu_tracking] Start [7fb732ae84c0]
    [SNMPFetcher] Fetch with cache settings: SNMPFileCache(base_path=PosixPath(’/omd/sites/BWI/tmp/check_mk/data_source_cache/snmp/ZOSBWIUCSFI-A’), max_age=MaxAge(checking=0, discovery=1
    20, inventory=120), disabled=False, use_outdated=False, simulation=False)
    Not using cache (Too old. Age is 316 sec, allowed is 0 sec)
    [SNMPFetcher] Execute data source
    No persisted sections loaded
    SNMP scan:
    Getting OID .1.3.6.1.2.1.1.1.0: Executing SNMP GET of .1.3.6.1.2.1.1.1.0 on ZOSBWIUCSFI-A
    => [b’Cisco NX-OS™ ucs, Software (ucs-6400-k9-system), Version 9.3(5)I42(1b), RELEASE SOFTWARE Copyright (c) 2002-2021 by Cisco Systems, Inc. Compiled 6/24/2021 0:00:00’] OCTETSTR
    b’Cisco NX-OS™ ucs, Software (ucs-6400-k9-system), Version 9.3(5)I42(1b), RELEASE SOFTWARE Copyright (c) 2002-2021 by Cisco Systems, Inc. Compiled 6/24/2021 0:00:00’
    Getting OID .1.3.6.1.2.1.1.2.0: Executing SNMP GET of .1.3.6.1.2.1.1.2.0 on
    => [b’.1.3.6.1.4.1.9.12.3.1.3.2340’] OBJECTID
    b’.1.3.6.1.4.1.9.12.3.1.3.2340’
    Using cached OID .1.3.6.1.2.1.1.1.0: ‘Cisco NX-OS™ ucs, Software (ucs-6400-k9-system), Version 9.3(5)I42(1b), RELEASE SOFTWARE Copyright (c) 2002-2021 by Cisco Systems, Inc
    . Compiled 6/24/2021 0:00:00’

last line
[cpu_tracking] Stop [7fb7329a1eb0 - Snapshot(process=posix.times_result(user=0.21999999999999975, system=0.010000000000000009, children_user=0.0, children_system=0.0, elapsed=0.24000000022351742))]
[snmp] Success, execution time 11.2 sec | execution_time=11.150 user_time=0.990 system_time=0.090 children_user_time=0.000 children_system_time=0.000 cmk_time_snmp=10.060 cmk_time_agent=0.000

In your first screenshots you see that SNMPv2 is working and v3 not. I think the first discovery was done with v2 enabled and that’s the reason why you see the services but get no information now after switching to v3.

I deleted the device and readded it, never using snmpv2. The device doesn’t have a v2 community on it, only v3 user.

What i not see from your other posts - is this a RAW edition or enterprise?
If you use the enterprise i would test to switch the SNMP backend for this one host to the classic one. I had already some devices that had problems with the Python backend and where working without problem with the classic one. This was especially with SNMPv3 the case.

This is enterprise.

How do I switch to “classic” snmp backend? I’m happy to test it.

This is a option inside the host configuration.
Section - SNMP rules
image

Ok, I made that change, and I get the following in connection tests
It is green for snmpv1/v2 but those aren’t configured. V3 is complaining about the password being too short, but it’s working, see second picture