[Solved] Graphviz-gd dependency error

CMK version: Checkmk Enterprise Edition 2.1.0p25
OS version: RHEL 8.7

Error message:

 Problem: graphviz-2.40.1-43.el8.i686 has inferior architecture
  - package graphviz-gd-2.40.1-43.el8.x86_64 requires graphviz = 2.40.1-43.el8, but none of the providers can be installed
  - cannot install both graphviz-2.40.1-44.el8.x86_64 and graphviz-2.40.1-43.el8.x86_64
  - cannot install the best update candidate for package graphviz-2.40.1-43.el8.x86_64
  - problem with installed package graphviz-gd-2.40.1-43.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@monitoring01 ~]$ dnf list installed |grep graphviz
graphviz.x86_64                               2.40.1-43.el8                               @rhel-8-for-x86_64-appstream-rpms
graphviz-gd.x86_64                            2.40.1-43.el8                               @codeready-builder-for-rhel-8-x86_64-rpms

Doing a regular ‘dnf update’ here and getting the following error.
I know that graphviz-gd was installed as a dependency for checkmk, maybe someone knows why and how this error comes up now and how to fix it?


The 2 packages need to be the same version, and only one of them is in the repo.

I used the “–nobest” dnf option to not update this specific package.

I ran into the exact same problem. After some head scratching and looking at the lines below the initial error, the one that stood out was:

none of the providers can be installed

This led me to investigate what had been providing the package before. I discovered that the CodeReady Linux Builder repo was not enabled after I had previously flushed the DNF config when having a connectivity issue.

I ran:

subscription-manager repos --enable codeready-builder-for-rhel-8-x86_64-rpms

and after this the package could update no problem.

Thanks hmaal, that sounds good and I marked this as the solution.
Sounds weird though as I enabled the CodeReady Builder Repo. Thanks again.