Virtual Appliance in OpenStack

Hello,

I was wondering if anyone has tried converting and running the OVA virtual appliance in OpenStack. Not really sure if this is even possible but I’ve tried the conversion from OVA to QCOW2 using virt-v2v and it fails with a mount related error:

# virt-v2v -v -i ova virt1-demo-1.4.16.ova -of qcow2
---
virt-v2v: error: mount: mount exited with status 32: mount: /dev/sda is 
write-protected, mounting read-only
mount: unknown filesystem type '(null)'

Many thanks!

Just found this answer on the Appliance web page…

Yes. You basically need to download the OVA file we provide, unpack it and convert the shipped virtual HDDs from the VMDK format to, e.g., the QCOW2 format. You can then copy these virtual hard disk files to the paths where your VM images are stored. Finally, create a VM with the parameters of your choice and use the just converted QCOW2 disk images as harddisks.

You may want to take a look at the “virt1.ovf” file to see which parameters to use for the VM you create in the next steps. Some things are mandatory:

   You need to give the VM at least 2 GB of memory.
   You need to use the BOTH of the hard disks you just converted.
   Use virtio for the disks for best performance.