Virtual Appliance NTP-Problem

Hallo zusammen,

ich bin zur Zeit dabei meine Checkmk Installation von Ubuntu auf die Appliance zu migrieren.
An den Installationen wo ich die virt Appliance einsetze, habe ich einen NTP-Alarm.


Bei den Hardware-Applinaces tritt der Fehler nicht auf.

Ich setze immer die Version v1.4.17 ein.

Hat jemand eine Idee was da schief läuft und kann mir weiterhelfen?

Viele Grüße

Sebastian

Hallo Sebastian,

das kann unterschiedliche Ursachen haben.
Entweder ist der NTP Server nicht erreichbar oder er tut nicht das, was der ntpd erwartet.
Wenn du dich als root anmelden kannst/möchtest, kannst du die Ausgabe von
ntpq -p
posten, da kann man ganz gut sehen, wo das Problem liegt.

@aeckstein die Meldung würde anders lauten, wenn der NTP Server gar nicht erreichbar wäre.

Ich habe dieses Verhalten schon mehrfach gesehen. Kann es zufällig sein, dass der NTP Server ein Windows ist @sstermann? Microsoft baut in Windows nur eine verkrüppelte NTP Software ein. Kannst du in dem Falle mal gegen ein anderen NTP Server testen?

Hi Robin,

bei mir im RZ habe ich den NTP-Dienst von einer Sophos XG eingetragen, in dem Kundennetz ist es ein Windows Dienst.
Bei mir im eigenen RZ muss ich schauen ob ich temporär die Anfragen ins Office-Tunneln kann und dort einen Cisco-Switch zu nutzen.

Hi @sstermann

Soweit ich weiß hat die Sophos XG keinen NTP Server mehr. Die SG hatte einen aber die XG nicht :upside_down_face: Und Sophos hat es seit 7 Jahren nicht geschafft einen zu implementieren…

https://community.sophos.com/sophos-xg-firewall/f/discussions/11100/sophos-as-ntp-source

Was geht ist der Workaround mit einer NAT Regel aber das ist auch nicht so schön.
https://community.sophos.com/sophos-xg-firewall/f/recommended-reads/118433/using-v18-nat-to-achieve-ntp-proxy-like-functionality/

Und mit Windows und NTP habe ich leider auch nicht so gute Erfahrungen gemacht.

Das ganze Thema schreit förmlich nach einem “richtigen” NTP Konzept. :grinning:

Freundliche Grüße
Norm

Hi,

mein Fehler, im RZ steht noch eine SG.

Da habe ich leider keinen Einfluss drauf :wink: Ich bin mache dort nur Netzwerkthemen und CheckMK als Managed Service für die Voice-Infrastruktur.

Ok, intern funktionert der NTP-Dienst nachdem ich die Quelle geändert habe.
Dann vermute ich, das dies die Lösung bei dem Kunden auch sein wird, dort erreiche aktuell nur niemanden.
Danke für die Hilfe.

Weiss nicht ob das was nützt. Ich habe die eine oder andere CRE auf virtuellen Centos8 laufen, und da ist der Chronyd nicht mit einem externen NTP Server verbunden, sondern guckt auf die Hardwareuhr des VM Host.
Meine Notizen dazu.:

To enable the PHC device, do the following on the guest OS:
Set the ptp_kvm module to load after reboot.
echo ptp_kvm > /etc/modules-load.d/ptp_kvm.conf
Add the /dev/ptp0 clock as a reference to the chrony configuration:
echo “refclock PHC /dev/ptp0 poll 2” >> /etc/chrony.conf

Restart the chrony daemon:
systemctl enable chronyd
systemctl start chronyd
systemctl restart chronyd

To verify the host-guest time synchronization has been configured correctly, use the chronyc sources command on a guest. The output should look similar to the following:

# chronyc sources
210 Number of sources = 1
MS Name/IP address         Stratum Poll Reach LastRx Last sample
===============================================================================
#* PHC0                          0   2   377     4     -6ns[   -6ns] +/-  726ns

Hallo,

Wir hatten dass Problem bei uns gelöst in dem wir die IP des NTP servers anstatt des FQDN eingetragen haben. Das Problme ist auch auf anderen RedHat Installationen aufgetreten was im Augenblick noch untersucht wird.
Muss aber nicht zwingend die Lösung für das o.g. Problem sein. Wir haben halt nur festgestellt das der NTP server zeitweise vom Host nicht erreichbar war. Kann natürlich am DNS liegen.

Gruß

Michael