Availability report with service time showing incorrect information

For one host I have a service defined with “Service custom attributes” defined as “SERVICE_PERIOD xxxx” where xxxx is a time period defined in wato configuration “Time Periods”. This is set to monday to friday between 06:00 and 20:00. So everything outside that, including weekends are not in the SLA.

This service has been unavailable for a few times last month, also outside the configured time period. I was expecting that when I click on “Availability” for this service, and in the report details I select “Base report only on service times”, the times the service was unavailable outside the service window would not be included. However, they are still included and visible in the “Timeline”, making the report incorrect for the agreed SLA and set Time period. When I select “Base report only on non-service times”, it shows the service asif it had no downtime at all.

Am I misunderstanding the concept of these service times and the report options? I’m running Check_mk 1.6.0p11.

Hello Jeroen,

well I aswell hit the same “problem” thinking that it is that easy, some month ago:slight_smile: (Report: Availability report based on Time Periods (not service times))

You have to configure first service periods for Hosts & Services, where you can reference to the timeperiods. Then you can use them in Availability Reports for excludes for example.

I think I already have it set up like that:

  1. created a Time Period in “Wato / Time Periods”
  2. created a “Service period for services” rule for the folder the affected hosts are in (main directory), and reference the timeperiod in “SERVICE PERIOD FOR SERVICES”

It shows up when i click on a service in the “Service custom attributes” field.

In the “Availability / Configure details for the report” section when clicking on a service, I seem to have no other option other then “Base report only on service time”. Nothing specific to the item I created, so I assume it should work with the service times I created.

I just noticed this forum post from May 5th where this problem in 1.6.0.p11 is confirmed as a bug:

Ah that explains it :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.