Error 0x8024A000 on windows_updates.vbs

Hi there,

We seem to have a problem with the windows_updates.vbs plugin that’s been deployed to our servers. The problem is not present on all of them and is comparable to the following thread :
(Activating Windows Update plug in)

Had a look at the VBS and I’ve pinpointed the error on this line :
If AutomaticUpdates.DetectNow <> 0 Then

With the following result :
c:\Program Files (x86)\checkmk\service\plugins>cscript windows_updates.vbs
Microsoft ® Windows Script Host Version 5.8
Copyright © Microsoft Corporation. All rights reserved.
?c:\Program Files (x86)\checkmk\service\plugins\windows_updates.vbs(59, 1) (null): 0x8024A000

User aeckstein stated that it might be caused by the Windows Service itself (in that thread mentioned) but :

  1. there have been some updates on the 17th (so yesterday)
  2. ran the Windows update manually and it states that the PC is up to date
  3. something odd though : updates were installed : says that this was done somewhere in June 2018
  4. the service runs fine and can be started / restarted

Version of CheckMK : 1.6.0p19
And the location of that vbs : C:\Program Files (x86)\checkmk\service\plugins

Thanks for any help :slight_smile:
/dimi

I depends on your configuration of the Windows update service on this machine.
If it is configured that it only searches interactively for updates than it is clear that you can search and install updates manually without problem but the script throws errors.

Danke Andreas :slight_smile:

This might be a stupid question but you’re talking about that “interactive” mode? Do you mean the option between the forced way and the manual option? We’re actually using SCCM to deploy our updates and for this server, the software updates are deployed as “available”.
I’ve also checked this location : HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate\AU and the key NoAutoUpdate is set to 1. As expected…
Out of curiousity, I’ve set this key to 0 and restarted the service and restarted the VBS : same error. Deleted the key, restarted the service, stopped the SCCM client (so it doesn’t overwrite this with its client options) : and alas, the same error in that VBS.

Small update : I created this bare bones VBS :

Set AutomaticUpdates = CreateObject(“Microsoft.Update.AutoUpdate”)
AutomaticUpdates.detectnow()

And it’s the same problem - so it’s a problem with the Microsoft Update service and not really with the script…

You can have a look at the update log files.
If you find something like the line.

Can not perform non-interactive scan if AU is interactive-only

Then you have the mentioned interactive only problem.

1 Like

Indeed - that was present in that log file! I’ve been reading up on it and it might have something to do with the reg key I mentioned above? But thanks for the pointer!