Not able to delete some comments

CMK version: 2.1.0p9cee
OS version: Debian 11

Error message: There is no error message - I saw that there are some old comments on some services. I tried to delete them, but noting happened. I marked them with checkbox activated, but nothing happened again.

image

Unfortunately it’s a lot - It was all from one colleague, I did it with the REST API and I think I setup the “permanent” options.

Any ideas? For me it seems to be bug?

Greetz
Ovrld

1 Like

No tips how I can delete the old comments? I tried it several times - but nothing happened

That looks like a comment to an acknowledgement. Is the corresponding acknowledgement still present? if yes, can you try to delete the acknowledgement?

No - it’s just the comment.

1 Like

CMK version: 2.1.0p12 (RAW)
OS version: CentOS

Error message: Also have this issue.
No error, unable to remove comment and remove ACK does not help.
Ack/comments made with options (Sticky: no | send notification: yes | persistent comment: yes)


@andreas-doehler - Is this the same issue that should already be solved in (Werk: 12697)?

Forgot to add, this issue started for us after upgrade from 2.0.0p23 to 2.1.0p12.

The issue still persist with version 2.1.0p14 CEE

Is there any possibility to fix that? I have around 40 of them and some on very important services. We already had some trouble about this.

Since we use the CEE - is there a way to let the developers know about the issue? A feedback formular or mail address?

1 Like

Hello! feedback@checkmk.com might be the right email address for bugs and feedback.

1 Like

Thank you - I will write a mail to that address.

Fyi - issue still occurs in 2.1.0p15 CEE

And issue occurs in 2.1.0p16 CEE.

I wrote a email but still today no fix or something.

Hello,
I have recently added a few hundred comments focused on services, these have no “expiry date” and I can’t delete them manually, no matter how much I follow the steps of “Select all > Remove comments > remove > Confirm” when I go back to the comments page I find that these have not been deleted.
thanks in advance.

CMK version:2.1
OS version: ubuntu 20.4

Seems to be a bug not fixed. No workarounds or explanation provided, only report to feedback@checkmk.com and hope for the best.

#Not able to delete some comments#

I tried to connect all of these issues together somehow but just in case I’ll also put a note here: the team knows about the issue, and they are working on it. I do not yet have any ETAs, but I’ll do my best to keep you all updated on how it goes.

3 Likes

I hoped it’s fixed in 2.1.0p19:

  • 15119 FIX: Fix service custom notes for multiple hosts

but it’s not :frowning: Still inside. I wait since August 2022 to get this fixed

Edit
No fix in 2.1.0p20 CEE :frowning: Still waiting

Hi! I checked and it seems to be a different issue. The one with un-deleted comments is still in progress but should be soon now.

3 Likes

Hi @Sara
Any new progress on this?

This is still a major issue in our workflow as we use them daily and in automation.

1 Like

Hello @mareh,

From what I can see it is still in progress of implementation.

1 Like